Uh -oh. You'll need a newer version of the Flash Player to enter the market..

You can go here to download the new Flash Player (version 8 is needed).